High response times in Internal API

Major incident Web Application EU data center Partner Integrations & Developer Portal (Open API)
2026-02-25 03:41 CET · 1 hour, 54 minutes

Updates

Resolved

The incident High response times in Internal API, which occurred between 2026-02-25 02:15 CET/CEST and 2026-02-25 04:06 CET/CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

February 25, 2026 · 05:35 CET
Monitoring

We applied a fix and are monitoring the results currently.

February 25, 2026 · 05:07 CET
Update

We found the underlying issue and are about to apply counter measures

February 25, 2026 · 04:52 CET
Investigating

We are still investing the root cause

February 25, 2026 · 04:26 CET
Investigating

The latency is still high so we are investing additional causes

February 25, 2026 · 04:09 CET
Monitoring

We identified a very high and unusual request, causing a very high load and preasure on our system. We are closely monitoring this at moment

February 25, 2026 · 04:02 CET
Investigating

Response times of the Web Application are higher than usual. We are currently investigating the issue.

February 25, 2026 · 03:41 CET

← Back