Partial Outage across multiple systems
Updates
Our Response
Our response followed the incident timeline:
16:54 CEST — Degradation detected
Monitoring identified rising error rates and increased response times in the Web Application. Investigation began immediately.
17:07 CEST — Incident declared
The incident was formally declared, coordination started, and mitigation planning began.
17:20–17:35 CEST — Initial containment measures applied
The team introduced targeted restrictions to the affected functionality in order to reduce pressure on the broader platform and protect overall availability.
17:39–18:06 CEST — Stabilization attempts under way
Additional recovery steps were taken to replace degraded application instances and adjust platform settings so the service could recover more safely under load.
18:30–20:10 CEST — Root technical pressure identified and reduced
The team identified database connection contention and locking behaviour as a major factor in the ongoing degradation. Operational measures were applied to reduce the blocking condition and throughput began to recover.
21:15–21:45 CEST — Final recovery steps completed
Remaining rollout and infrastructure blockers were cleared and configuration adjustments were completed.
22:01 CEST — Incident resolved
The platform recovered to a stable state and the incident was closed. The temporarily restricted functionality remained disabled overnight as a precaution and was restored the following morning after additional monitoring.
Resolution
The incident was resolved through a staged approach:
Containment — We temporarily restricted the affected functionality to reduce triggering conditions and protect platform-wide availability.
Remediation — We applied configuration and operational changes to reduce database connection contention, remove blocking conditions, and stabilize the platform.
Verification — We monitored platform recovery, kept the affected functionality restricted overnight as a safety measure, and restored it only after confirming improved stability the following morning.
Lessons Learned
Recovery controls must isolate affected functionality quickly.
Targeted feature restrictions were effective in reducing pressure on the broader platform and remain an important containment measure for platform-wide stability.
Connection contention needs stronger protective controls.
The incident showed that elevated request pressure in one feature area can create broader platform degradation when supporting resources become constrained. Additional protection and tuning are required to reduce this risk.
Opportunity for Improvement
Streamlining mid-incident operational adjustments. We can elevate our incident response capabilities by making critical runtime settings more dynamic. This optimization will allow the team to pivot faster and maintain peak efficiency during high-pressure scenarios.
Monitoring and recovery procedures will be improved further.
Follow-up work has been identified to improve early detection, reduce recovery time, and lower the chance of similar platform-wide degradation in the future.
The incident ‘Partial Outage across multiple systems’, which occurred between 2026-06-22 17:07 CEST and 2026-06-22 17:59 CEST, has been resolved.
Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.
If you continue to experience any problems, please open a ticket with our support team.
We apologize for any inconvenience caused.
In the process parts of the integration management section had to be deactivated.
The Web Client still shows partial outages. The team is working on a solution.
The team has implemented countermeasures and is monitoring the situation. The Integrations section of the web application is currently unavailable.
The team has identified a possible root cause and is implementing countermeasures.
We are currently experiencing performance degradation and intermittent availability across several systems. Some features may be slow or unavailable. Our team is investigating the root cause.
← Back
PerfectGym Next Status