Analytics data is partially not up to date

Minor incident Web Application EU data center
2026-07-06 09:52 CEST · 7 hours, 42 minutes

Updates

Resolved

The incident ‘Analytics data is partially not up to date’, which occurred between 2026-07-06 09:52 CEST and 2026-07-06 17:35 CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

July 6, 2026 · 17:35 CEST
Monitoring

A fix was deployed. Data is updating.

July 6, 2026 · 11:33 CEST
Update

We have identified the root cause of the issue and are actively working on a resolution.

July 6, 2026 · 09:56 CEST
Investigating

Users cannot see the latest analytics data of some key reports. We are currently investigating the issue.

July 6, 2026 · 09:52 CEST

← Back