Stripe Payments failed due to rate limiting

Minor incident Web Application EU data center
2026-08-28 06:42 CEST · 52 minutes

Updates

Resolved

The incident ‘Stripe Payments failed due to rate limiting’, which occurred between 2026-08-28 04:25 CEST and 2026-08-28 07:32 CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

August 28, 2026 · 07:32 CEST
Monitoring

Stripe Payments for payment runs failed due to rate limiting on stripe side. Our engineering team has identified the cause and is working on a fix. We will provide a further update as soon as the issue is resolved. We apologize for any inconvenience caused.

August 28, 2026 · 06:47 CEST
Investigating

We are currently investigating an issue where payments using Stripe are failing to process. Payments with other payment providers are not affected. Our engineering team is working on identifying the cause. We will provide a further update as soon as more information is available. We apologize for any inconvenience caused.

August 28, 2026 · 04:25 CEST

← Back