Analytics data Update within the software is delayed
Minor incident
Web Application
EU data center
Web Application
Web Application
2026-09-08 10:11 CEST
· 3 hours, 57 minutes
Updates
Update
September 8, 2026 · 10:12 CEST
Root cause has been found and a Fix deployed. Data is currently being refreshed.
Investigating
September 8, 2026 · 10:11 CEST
Users cannot see the latest analytics data. We are currently investigating the issue.
← Back
PerfectGym Next Status